Требования


При наличии GD-библиотеки (доступна по адресу » http://www.libgd.org/), вы можете создавать и изменять изображения.

Форматы изображений, с которыми можно работать, зависят от версии установленной GD, а так же от наличия других библиотек, к которым GD может обращаться для получения доступа к тем или иным форматам. Версии GD страрше, чем gd-1.6, поддерживают GIF изображения, но не поддерживают PNG, в то время как версии выше gd-1.6 и ниже gd-2.0.28 поддерживают PNG, но не поддерживают GIF. Поддержка GIF снова включена в версии gd-2.0.28.

Замечание: Начиная с PHP 4.3, GD библиотека встроена в PHP. Эта встроенная версия имеет несколько дополнительных возможностей, таких как альфа-сопряжение. Рекомендуется использовать именно встроенную версию, так как ее код более стабилен и имеет лучше поддерживается разработчиками.

Возможно, вы пожелаете расширить GD, чтобы обрабатывать больше форматов изображений.

Поддерживаемые форматы изображений
Формат изображения Необходимая библиотека Замечания
gif   Поддерживается только в версиях GD старше gd-1.6 или новее gd-2.0.28. Поддержка Read-only GIF доступна в PHP 4.3.0 во встроенной GD-библиотеке. Write поддержка доступна с PHP 4.3.9 и PHP 5.0.1.
jpeg » http://www.ijg.org/ При сборке библиотеки jpeg (перед сборкой PHP) необходимо включить настройку --enable-shared на этапе конфигурирования. Если этого не сделать, на этапе конфигурирования сборки PHP будет выдана ошибка libjpeg.(a|so) not found.
png » http://www.libpng.org/pub/png/libpng.html Поддерживается только в версиях GD выше gd-1.6.
xpm » ftp://metalab.unc.edu/pub/Linux/libs/X/!INDEX.html Если в системе установлено окружение X-Environment, то бибилиотека уже доступна.

Можно расширить функционал GD для работы с различными шрифтами. Доступные библиотеки шрифтов:

Доступные библиотеки шрифтов
Библиотека шрифтов Загрузка Замечания
FreeType 1.x » http://www.freetype.org/ Эта возможность устарела и будет обязательно удалена в будущем.
FreeType 2 » http://www.freetype.org/  
T1lib » ftp://sunsite.unc.edu/pub/Linux/libs/graphics/) Поддержка шрифтов Postscript Type 1.