Требования


Для установки SSH2 требуется наличие установленных библиотек » OpenSSL и » libssh2. Убедитесь, что указанные библиотеки присутствуют в системе. Типичным названием пакета может быть openssl-dev.

Необходима версия libssh2 1.2 или новее. Однако возможно, что новые релизы pecl/ssh2 потребуют более новые версии (смотрите примечания к релизу).

Функция ssh2_auth_agent() доступна только с версией libssh >= 1.2.3.

Поддержка канальных потоков в stream_set_timeout() доступна только с версией libssh >= 1.2.9.

Libssh2 поставляется в двух вариантах: gcrypt или openssl. Некоторые дестрибутивы Linux собирают libssh2 с библиотекой gcrypt, некотрые с openssl. Libssh2 имеет некоторые проблемы при компиляции с gcrypt, поэтому используйте версию с openssl.